Forum openmoko-fr.org

Forum de la communauté francophone autour du projet OpenMoko

Vous n'êtes pas identifié.

Annonce

Bienvenue sur ce forum.

Face à un afflux de spammers, les inscriptions ont été désactivée.
Si vous souhaitez vous inscrire, il faudra en faire la demande auprès du webmaster (voir la section "Contact" sur le Blog).

#1 12-07-2009 13:44:16

marou
Cool-Moko
Date d'inscription: 04-04-2009
Messages: 26

installer neovento après Android

Bonjour,
j'ai installé par curiosité Android sur mon Openmoko avec la l'installation simplifié.

Je souhaiterai re-installer une autre distribution "Neovento" mais je n'y parviens pas.
J'utilise les deux commandes ci-dessous et quand je boot en fin de télé-chargement je retrouve la distribution Android
./dfu-util -a kernel -R -D uImage.bin
./dfu-util -a rootfs -R -D neovento5.6_GTA02.jffs2

Comment faut-il re-installer le bootloader d'origine de OM2008 ?

Merci de votre aide

Hors ligne

 

#2 12-07-2009 14:05:22

swap38
AdMoKostrateur
Lieu: Grenoble
Date d'inscription: 21-07-2008
Messages: 766
Site web

Re: installer neovento après Android

questions bêtes :
tu as retiré la carte micro-SD qui a servi à l'install de android ?
tu boot comment ?
as-tu essayer de booter depuis le menu NOR (aux+power) ?


"There's no place like ~"

L'APRIL a passé la barre des 5000 adhérents, mais l'effort continue. Soutenez l'APRIL

Hors ligne

 

#3 12-07-2009 20:04:37

marou
Cool-Moko
Date d'inscription: 04-04-2009
Messages: 26

Re: installer neovento après Android

Bonjour Swap38, (je suis originaire de Grenoble porte de l'ouest à côté de l'hôtel des impôts)

je reprend l'installation, sans la carte micro-SD et en boot NOR

# ./dfu-util -a kernel -R -D uImage.bin
dfu-util - (C) 2007 by OpenMoko Inc.                           
This program is Free Software and has ABSOLUTELY NO WARRANTY   

Opening USB Device 0x0000:0x0000...
Claiming USB DFU Runtime Interface...
Determining device status: state = appIDLE, status = 0
Device really in Runtime Mode, send DFU detach request...
Resetting USB...
Opening USB Device...
Found Runtime: [0x1d50:0x5119] devnum=3, cfg=0, intf=0, alt=3, name="kernel"
Claiming USB DFU Interface...
Setting Alternate Setting ...
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
Transfer Size = 0x1000
bytes_per_hash=38568
Starting download: [##################################################] finished!
state(2) = dfuIDLE, status(0) = No error condition is present
Done!
Resetting USB to switch back to runtime mode


# ./dfu-util -a rootfs -R -D neovento5.6_GTA02.jffs2
dfu-util - (C) 2007 by OpenMoko Inc.                                         
This program is Free Software and has ABSOLUTELY NO WARRANTY                 

Opening USB Device 0x0000:0x0000...
Claiming USB DFU Runtime Interface...
Determining device status: state = appIDLE, status = 0
Device really in Runtime Mode, send DFU detach request...
Resetting USB...
Opening USB Device...
Found Runtime: [0x1d50:0x5119] devnum=6, cfg=0, intf=0, alt=6, name="rootfs"
Claiming USB DFU Interface...
Setting Alternate Setting ...
Determining device status: state = dfuIDLE, status = 0
dfuIDLE, continuing
Transfer Size = 0x1000
bytes_per_hash=4249354
Starting download: [##################################################] finished!
state(2) = dfuIDLE, status(0) = No error condition is present
Done!
Resetting USB to switch back to runtime mode

A la première mise sous tension, moteur du vibreur vibre 1 coup puis le message ci-dessous s'affiche:
[    0,000] Unknown boot option `g_ether.devhost_addr=00:FF:11:01:04:20` etc...
Après 4 fois ce message j'ai "debian-gta02 login:_


Avec la carte micro-SD 1er partition 2Go Fat32, deuxieme partition 5,3Go Ext3. les deux partitions sont formatées.
A la premiere mise sous tension, le moteur du vibreur vibre 1 coup, puis l'openmoko boot. Il affiche differents messages puis debian-gta02 login:_

Je n'ai en aucun cas l'image d'openmoko.

Merci de votre aide

Hors ligne

 

#4 13-07-2009 08:51:19

Burn2
MoKorateur
Date d'inscription: 15-05-2009
Messages: 1782

Re: installer neovento après Android

Reflash l'uboot avec QI. wink
Edit: si tu n'as plus l'image d'openMOko c'est normal, quand tu installes koolu il installe qi à la place d'uboot et il n'y a pas de logo de boot.

Dernière modification par Burn2 (13-07-2009 08:51:56)


Fr A6 - Android 1.5
Aucun fix, A6 pur. (donc bug du buzz inside hmm )

Hors ligne

 

#5 19-07-2009 22:01:19

marou
Cool-Moko
Date d'inscription: 04-04-2009
Messages: 26

Re: installer neovento après Android

Bonjour, et merci pour l'aide.

sur la page web http://openmoko-fr.org/wiki/index.php/Uboot-envedit
j'ai récupéré le fichier dfu-util -a u-boot_env -D original-u-boot_env.bin que j'ai flashé

# ./dfu-util -a u-boot_env -D original-u-boot_env.bin

A la mise sous tension avec le bouton power l'Openmoko boot comme avec l'android (le moteur du vibreur vibre 1 coup)

Si je boot en NOR sur "Boot", là je boot j'obtiens bien le neovento.

Est-il possible de démarrer l'openmoko avec la touche power et obtenit dans mon cas neovento, sans booter en NOR ?

Hors ligne

 

Pied de page des forums

Propulsé par FluxBB 1.2.20
Traduction par FluxBB.fr

Hébergé par :
Bearstech