Forum openmoko-fr.org

Forum de la communauté francophone autour du projet OpenMoko

Vous n'êtes pas identifié.

Annonce

Bienvenue sur ce forum.

Face à un afflux de spammers, les inscriptions ont été désactivée.
Si vous souhaitez vous inscrire, il faudra en faire la demande auprès du webmaster (voir la section "Contact" sur le Blog).

#1 05-01-2013 20:25:49

José Charters
Cool-Moko
Date d'inscription: 26-04-2012
Messages: 23

accès ssh via le wifi

Bonjour,

J'ai installé qtmoko V50 depuis plus d'un mois et je suis content de cette version.

Le téléphone fonctionne bien, ce qui n'était pas le cas pour moi avec les version 48 et 49 où le son n'était pas toujours présent.

Mais j'ai un soucis que j'avais déjà avec la version 49.

Je veux me connecter en ssh via le wifi depuis mon pc. Il me répond invariablement : ssh: connect to host x.x.x.x port 22: Connection refused

Pourtant via la connection usb, j'arrive sans difficulté à me connecter depuis mon PC sur le neo. Mais en wifi impossible.

Depuis le neo, j'accède à internet via le wifi. J'ai même pu installé quelques applis.

Je sèche lamentablement. J'ai bien sûr cherché sur internet, mais je ne comprends pas tout.

J'ai cru comprendre qu'il y a avait un soucis avec ipv6, mais bien qu'ayant essayé la solution, je n'ai eu aucun résultat.

Quelqu'un a t il une idée ?

Merci

José

Hors ligne

 

#2 06-01-2013 10:04:00

Trim
Addicted-Moko
Lieu: Suisse :)
Date d'inscription: 02-12-2009
Messages: 233

Re: accès ssh via le wifi

Hello!

J'ai le même problème que toi et j'ai trouvé le post suivant : http://www.developpez.net/forums/d73318 … ost4253615 .Il faut effectivement écouter sur toutes les adresses avec "ListenAddress 0.0.0.0" (dans le fichier /etc/ssh/sshd_config du téléphone) et vérifier que ton routeur ne bloque pas les connexions ssh à travers le wifi.

Je n'ai pas encore résolu le problème chez moi, parce que je n'ai pas contrôlé ce que mon routeur faisait, mais je pense que c'est sûrement mes règles de routages qui ne le permettent pas.


GTA04 avec QtMoko compilé maison

Hors ligne

 

#3 06-01-2013 13:23:12

José Charters
Cool-Moko
Date d'inscription: 26-04-2012
Messages: 23

Re: accès ssh via le wifi

Merci beaucoup pour cette réponse.

J'avais vu cette solution, mais cela n'avait pas donné de résultat.

Je viens de ressayer : J'ai décommenté cette ligne dans /etc/ssh/sshd_config - ListenAdress 0.0.0.0
Ensuite j'ai relancé sshd avec la commande /etc/init.d/ssh restart
Tout cela sur le gta04.

Ensuite depuis mon pc, je tente un ssh root@X.X.X.X.
Même résultat : connect to host x.x.x.x port 22: Connection refused

Je pense que j'ai du raté quelque chose mais je ne vois pas quoi.

Bonne journée,

José

Hors ligne

 

#4 30-06-2013 21:38:34

Trim
Addicted-Moko
Lieu: Suisse :)
Date d'inscription: 02-12-2009
Messages: 233

Re: accès ssh via le wifi

Hello! J'ai enfin trouvé l'origine du problème smile

En fait, QtMoko protège l'accès ssh et le bloque pour être possible uniquement via le port usb par sécurité.

J'ai trouvé ça à l'étape 9.9 de la création d'image de QtMoko :

Step 9.9 - enable ssh access just on usb
========================================

* SSH root access can be dangerous on wifi or on GPRS, so enable it only on usb0

echo "# Enable ssh access just on usb" >> /media/card/etc/rc.local
echo "ip6tables -A INPUT ! -i usb0 -p tcp --dport 22 -j REJECT --reject-with tcp-reset; iptables -A INPUT ! -i usb0 -p tcp --dport 22 -j REJECT --reject-with tcp-reset" >> /media/card/etc/rc.local

* Manually edit /media/card/etc/rc.local and move "exit" 0 to the end of file:

nano /media/card/etc/rc.local

Ce qui est intéressant, c'est qu'ils modifient le fichier /etc/rc.local pour ajouter des règles réseaux (ils modifient l'ipv6 et l'ipv4, les deux commandes sont sur la même ligne séparée par un point-virgule).

J'ai modifié la ligne ainsi :

ip6tables -A INPUT ! -i usb0 -p tcp --dport 22 -j REJECT --reject-with tcp-reset;
iptables -A INPUT  -i hso0 -p tcp --dport 22 -j REJECT --reject-with tcp-reset

Je n'ai pas touché à l'ipv6 et j'ai dit de bloquer uniquement ssh sur l'interface du gprs qui est hso0 pour le GTA04 (la règle d'avant bloquait toutes les interfaces qui ne sont pas usb0).

Comme on vient de donner accès au téléphone à travers le wifi, il faut absolument ajouter un mot de passe au root en utilisant la commande passwd, sinon n'importe qui peut modifier ton téléphone.

Enfin, pour appliquer les changements, j'ai redémarré mon téléphone.

Dernière modification par Trim (30-06-2013 21:42:30)


GTA04 avec QtMoko compilé maison

Hors ligne

 

Pied de page des forums

Propulsé par FluxBB 1.2.20
Traduction par FluxBB.fr

Hébergé par :
Bearstech